Class ExtendedSSLSession
- All Implemented Interfaces:
SSLSession
SSLSession interface to support additional
session attributes.- Since:
- 1.7
-
Constructor Summary
Constructors -
Method Summary
Modifier and TypeMethodDescriptionbyte[]exportKeyingMaterialData(String label, byte[] context, int length) Generates Exported Keying Material (EKM) calculated according to the algorithms defined in RFCs 5705/8446.exportKeyingMaterialKey(String keyAlg, String label, byte[] context, int length) Generates Exported Keying Material (EKM) calculated according to the algorithms defined in RFCs 5705/8446.abstract String[]Obtains an array of supported signature algorithms that the local side is willing to use.abstract String[]Obtains an array of supported signature algorithms that the peer is able to use.Obtains aListcontaining allSNIServerNames of the requested Server Name Indication (SNI) extension.List<byte[]> Returns aListcontaining DER-encoded OCSP responses (using the ASN.1 type OCSPResponse defined in RFC 6960) for the client to verify status of the server's certificate during handshaking.Methods declared in class Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, waitModifier and TypeMethodDescriptionprotected Objectclone()Answers a new instance of the same class as the receiver, whose slots have been filled in with the values in the slots of the receiver.booleanCompares the argument to the receiver, and answers true if they represent the same object using a class specific comparison.protected voidfinalize()Deprecated, for removal: This API element is subject to removal in a future version.May cause performance issues, deadlocks and hangs.getClass()Answers the unique instance of java.lang.Class which represents the class of the receiver.inthashCode()Answers an integer hash code for the receiver.final voidnotify()Causes one thread which iswaiting on the receiver to be made ready to run.final voidCauses all threads which arewaiting on the receiver to be made ready to run.toString()Answers a string containing a concise, human-readable description of the receiver.final voidwait()Causes the thread which sent this message to be made not ready to run pending some change in the receiver (as indicated bynotifyornotifyAll).final voidwait(long time) Causes the thread which sent this message to be made not ready to run either pending some change in the receiver (as indicated bynotifyornotifyAll) or the expiration of the timeout.final voidwait(long time, int frac) Causes the thread which sent this message to be made not ready to run either pending some change in the receiver (as indicated bynotifyornotifyAll) or the expiration of the timeout.Methods declared in interface SSLSession
getApplicationBufferSize, getCipherSuite, getCreationTime, getId, getLastAccessedTime, getLocalCertificates, getLocalPrincipal, getPacketBufferSize, getPeerCertificateChain, getPeerCertificates, getPeerHost, getPeerPort, getPeerPrincipal, getProtocol, getSessionContext, getValue, getValueNames, invalidate, isValid, putValue, removeValueModifier and TypeMethodDescriptionintGets the current size of the largest application data that is expected when using this session.Returns the name of the SSL cipher suite which is used for all connections in the session.longReturns the time at which this Session representation was created, in milliseconds since midnight, January 1, 1970 UTC.byte[]getId()Returns the identifier assigned to this Session.longReturns the last time this Session representation was accessed by the session level infrastructure, in milliseconds since midnight, January 1, 1970 UTC.Returns the certificate(s) that were sent to the peer during handshaking.Returns the principal that was sent to the peer during handshaking.intGets the current size of the largest SSL/TLS/DTLS packet that is expected when using this session.default X509Certificate[]Deprecated, for removal: This API element is subject to removal in a future version.TheSSLSession.getPeerCertificates()method that returns an array ofjava.security.cert.Certificateshould be used instead.Returns the identity of the peer which was established as part of defining the session.Returns the host name of the peer in this session.intReturns the port number of the peer in this session.Returns the identity of the peer which was established as part of defining the session.Returns the standard name of the protocol used for all connections in the session.Returns the context in which this session is bound.Returns the object bound to the given name in the session's application layer data.String[]Returns an array of the names of all the application layer data objects bound into the Session.voidInvalidates the session.booleanisValid()Returns whether this session is valid and available for resuming or joining.voidBinds the specifiedvalueobject into the session's application layer data with the givenname.voidremoveValue(String name) Removes the object bound to the given name in the session's application layer data.
-
Constructor Details
-
ExtendedSSLSession
public ExtendedSSLSession()Constructor for subclasses to call.
-
-
Method Details
-
getLocalSupportedSignatureAlgorithms
Obtains an array of supported signature algorithms that the local side is willing to use.Note: this method is used to indicate to the peer which signature algorithms may be used for digital signatures in TLS/DTLS 1.2. It is not meaningful for TLS/DTLS versions prior to 1.2.
The signature algorithm name must be a standard Java Security name (such as "SHA1withRSA", "SHA256withECDSA", and so on). See the Java Security Standard Algorithm Names document for information about standard algorithm names.
Note: the local supported signature algorithms should conform to the algorithm constraints specified by
getAlgorithmConstraints()method inSSLParameters.- Returns:
- An array of supported signature algorithms, in descending order of preference. The return value is an empty array if no signature algorithm is supported.
- External Specifications
- See Also:
-
getPeerSupportedSignatureAlgorithms
Obtains an array of supported signature algorithms that the peer is able to use.Note: this method is used to indicate to the local side which signature algorithms may be used for digital signatures in TLS/DTLS 1.2. It is not meaningful for TLS/DTLS versions prior to 1.2.
The signature algorithm name must be a standard Java Security name (such as "SHA1withRSA", "SHA256withECDSA", and so on). See the Java Security Standard Algorithm Names document for information about standard algorithm names.
- Returns:
- An array of supported signature algorithms, in descending order of preference. The return value is an empty array if the peer has not sent the supported signature algorithms.
- External Specifications
- See Also:
-
getRequestedServerNames
Obtains aListcontaining allSNIServerNames of the requested Server Name Indication (SNI) extension.In server mode, unless the return
Listis empty, the server should use the requested server names to guide its selection of an appropriate authentication certificate, and/or other aspects of security policy.In client mode, unless the return
Listis empty, the client should use the requested server names to guide its endpoint identification of the peer's identity, and/or other aspects of security policy.- Returns:
- a non-null immutable list of
SNIServerNames of the requested server name indications. The returned list may be empty if no server name indications were requested. - Throws:
UnsupportedOperationException- if the underlying provider does not implement the operation- Since:
- 1.8
- See Also:
-
getStatusResponses
Returns aListcontaining DER-encoded OCSP responses (using the ASN.1 type OCSPResponse defined in RFC 6960) for the client to verify status of the server's certificate during handshaking.This method only applies to certificate-based server authentication. An
X509ExtendedTrustManagerwill use the returned value for server certificate validation.- Implementation Requirements:
- This method throws UnsupportedOperationException by default. Classes derived from ExtendedSSLSession must implement this method.
- Returns:
- a non-null unmodifiable list of byte arrays, each entry
containing a DER-encoded OCSP response (using the
ASN.1 type OCSPResponse defined in RFC 6960). The order
of the responses must match the order of the certificates
presented by the server in its Certificate message (See
SSLSession.getLocalCertificates()for server mode, andSSLSession.getPeerCertificates()for client mode). It is possible that fewer response entries may be returned than the number of presented certificates. If an entry in the list is a zero-length byte array, it should be treated by the caller as if the OCSP entry for the corresponding certificate is missing. The returned list may be empty if no OCSP responses were presented during handshaking or if OCSP stapling is not supported by either endpoint for this handshake. - Throws:
UnsupportedOperationException- if the underlying provider does not implement the operation- Since:
- 9
- See Also:
-
exportKeyingMaterialKey
public SecretKey exportKeyingMaterialKey(String keyAlg, String label, byte[] context, int length) throws SSLKeyException Generates Exported Keying Material (EKM) calculated according to the algorithms defined in RFCs 5705/8446.RFC 5705 (for (D)TLSv1.2 and earlier) calculates different EKM values depending on whether
contextis null or non-null/empty. RFC 8446 (TLSv1.3) treats a null context as non-null/empty.labelwill be converted to bytes using theStandardCharsets.UTF_8character encoding.- Implementation Requirements:
- The default implementation throws
UnsupportedOperationException. - Parameters:
keyAlg- the algorithm of the resultantSecretKeyobject. See the SecretKey Algorithms section in the Java Security Standard Algorithm Names Specification for information about standard secret key algorithm names.label- the label bytes used in the EKM calculation.labelwill be converted to abyte[]before the operation begins.context- the context bytes used in the EKM calculation, or nulllength- the number of bytes of EKM material needed- Returns:
- a
SecretKeythat containslengthbytes of the EKM material - Throws:
SSLKeyException- if the key cannot be generatedIllegalArgumentException- ifkeyAlgis empty,lengthis non-positive, or if thelabelorcontextlength can not be accommodatedNullPointerException- ifkeyAlgorlabelis nullIllegalStateException- if this session does not have the necessary key generation material (for example, a session under construction during handshaking)UnsupportedOperationException- if the underlying provider does not implement the operation- Since:
- 25
- External Specifications
-
exportKeyingMaterialData
public byte[] exportKeyingMaterialData(String label, byte[] context, int length) throws SSLKeyException Generates Exported Keying Material (EKM) calculated according to the algorithms defined in RFCs 5705/8446.RFC 5705 (for (D)TLSv1.2 and earlier) calculates different EKM values depending on whether
contextis null or non-null/empty. RFC 8446 (TLSv1.3) treats a null context as non-null/empty.labelwill be converted to bytes using theStandardCharsets.UTF_8character encoding.Depending on the chosen underlying key derivation mechanism, the raw bytes might not be extractable/exportable. In such cases, the
exportKeyingMaterialKey(String, String, byte[], int)method should be used instead to access the generated key material.- Implementation Requirements:
- The default implementation throws
UnsupportedOperationException. - Parameters:
label- the label bytes used in the EKM calculation.labelwill be converted to abyte[]before the operation begins.context- the context bytes used in the EKM calculation, or nulllength- the number of bytes of EKM material needed- Returns:
- a byte array of size
lengththat contains the EKM material - Throws:
SSLKeyException- if the key cannot be generatedIllegalArgumentException- iflengthis non-positive, or if thelabelorcontextlength can not be accommodatedNullPointerException- iflabelis nullIllegalStateException- if this session does not have the necessary key generation material (for example, a session under construction during handshaking)UnsupportedOperationException- if the underlying provider does not implement the operation, or if the derived keying material is not extractable- Since:
- 25
- External Specifications
-